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SRML Modelling Environment

e Introduction

service EasyBank is

components
EE : easyBank {
intOR[init] : x INTT;
intCR[term] : x FINAL;

regquires
I5 : invoiceService {

intGA[trigger]

provides

BU: buyer
wires
BE {
nodeh BU;
nodeB EB;

connector {
attachments {
placeOrder => 5;
product=>» 1i;

attachmentB {
placelrder => R;

interaction protocol

: default:;

straightP;

Functionalities:

*SRML code generation Wizard
*Use Case - SRML wizard
*SRML document visualization
*Syntax coloring

*Syntax checking / Error markers
*Code completion (CTRL-Space)
*Navigation (holding the CTRL key and
left-clicking)

*Code Folding

*Outline

*Quick Outline (press CTRL-O)



Start SRML Editor in MSc lab

e Lab sheet and materials

» Start Eclipse 3.4
e Create a new workspace e.g. workspace_ SRML

Workspace [Launcher

Select a workspace

Eclipse SOk stores your projects in a folder called a workspace.,
Choose a workspace folder to use for this session,

Wiorkspace: [f hornefhiongyif wurkspace_SF{r'-“lL| ] v Browse. ..

Llse this as the default and do not ask again

Ik, Carcel



http://www.cs.le.ac.uk/srml/
http://www.cs.le.ac.uk/srml/

Create a SRML project

(1) Open project wizard window from eclipse menu
File->New->Other el

MNew Alt+Shift+M » Java Project

Open File...

i

I |
Lk

Project...

Task

L2

Example...

L= =4S

P |

Other... Ctrl+M

[ New

Select a wizard

(2) Type SRML here to Y
search for SRML wizard. SRHL

= = Example EMF Model Creation Wizards

. L& Srmml Madel
(3) SeIeCt Srml PrOJeCt and = [= Xtext DSL Wizards
CI|Ck Nn eXt f2) srmil Editor file

strnl Project

~ [= Exarnples

I St Diaaram

@ < Back et = Firish Carcel




Write your first SRML - EasyBank

Step by Step

*Please refer to Lecturer note --
*http://www.cs.le.ac.uk/srml/tutorial/easyBank_example.pdf

EasyBarnPROCESS

EB:




Create project with SRML wizard
(4) Create new project: Use easyBank as deafult project name and click Next

= [x]

Xtext DSL srml Project —

Wtext OSL srml Project { ;

Project name: [easzank ]

| Use default locatior (315 )]

Lcation: SRML Wizard - General Information

Specify a name for SRML module (e.g. TravelBooking $xx)

SRML

SRML Module Mame  [easvBank )

3] = Back Mext = Firish Cancel

(5) Type easyBank as SRML Module name then click Cext



SRML Data Type

sorts: ProductType, BillType

ee (6) Add new datatype
SRML Wizard - Data Type sets -
Define data types used in the SRML specification Se|eCt [ S R M L
DataTypes] from SRML
Add default SRML orimitive Datatvoe data type window and
Primitive type click “Add” button to
© [SRML DataTypes] Add add a new data type
‘EasyBankType”
As shown on the left.
[WDats Juie Edit
Name  |EasyBankType ) 3ename
(7) Edit datatype
0K Cancel sets-
Select “EasyBankType”
@ < gark hext > Eirish Cancel node we just added and

click “Edit” on the right.
You should be able to
see the Data Type
Editor (next page)



SRML Data Type

MISRML Datatype Editor e (6) Add new data
T ok Tvoo structure to the data
Primitive Type = Enumeraction Type Imported Types type set -
In easyBank example, we
SRML DataType MappedTo Add will need these two data
ProductType . types: ProductType and
Hhpe [P “J|  pekts BillType , both of them
are mapped to primitive
data type String.
Ok Cancel
(7) Similarly, add other
= @ [SRML DataTypes] two data type sets: BOOL
® EasyBankType and STRING, which
® sooL mapped to Bool and

D' STRING String respectively, as
shown on the left.




SRML Specification

* We will use SRML Editor wizard to generate
following SRML Specification:

BUSINESS ROLE easyBank is

BUSINESS PROTOCOL invoiceService is

INTERRCTIONS
rev placeOrder INTERACTIONS
£ product:ProductType r&s dolnvoice
skr doinvoice L product:ProductType
£ product:ProductType >4bill:BillType
] bill:BillType BEHAVIOUR

snd forwardpBill
£ bill:BillType

ORCHESTRATION

BUSINESS PROTOCOL buyer is

INTERARCTIONS
snd placeOrder

&£ product:ProductType
rcv receiveBill

£ bill:BillType
BEHAVIOUR



SRML Specification

Textual representation for SRML notation:

_'? I‘EC[U.ESt “busineszProtocol invoiceService is=s
P repl? imports EasyBankType;
interactions
v comml1lt z r&s doInvoice
request product: ProductIype,
* cancel reply bill: BillType:
behavionr
< revoke
endbp
D) implies
& bookTrip~ .out>today 2 s°"=QUERIED
v I transition Regquest { IH'
triggeredBy bookIzip( reghest]
guardedBy state = LOGGED/& now§ < logih.Use ;
- 1 effects (bookIrip[ requést].cut > todays) implies qu?t{sta,,;E} = OUERIED

& (bookTzip[ reguest].ocut < today$) implies post(state)=END UNBOOKED

sends bookTrip([reply).out > todayf implies bookFlight[ reply]
bookFlight.from = bookTrip.from
bookFlight.to =booklrip.to
bookFlight.out=bookTrip.out
bookFlight.in=bookTrip.in

& bookFlight.traveller=bookTrip.traveller
& bookTrip.out<=today$§ implies bookIrip[ reply]

& bookTrip.Reply = false

&
&
&
&



SRML Specification-Business Role y

=
SRML Wizard - Specification

Create Business Role, Business Protocol, Layer Protocol and Interaction Protocol in the SRML
specification

= @ SRML Specification Busiress Role

Import
data type

BR pasyBank

Marne easvBank

Datatypes available

BOOL
STRIMG
<<
<| N<>
Add Delete
4 Node
(7 < Back Mext > Einish Cancel

(8) Add Specification
nodes -

Click on “SRML
Specification” node
than click “Add”
button, you can add
new Business Role,
Business Protocol
Layer Protocol and
Interaction Protocol
to SRML Specification.

(9) Import data type
sets — Import
EasyBankType to
Business Role
easyBank.



SRML Specification-Business Role

e ® (10) Add Interaction —
e v Select Business Role easyBank and click on
Name  [placeOrder ] Add Button to add a new interaction. Here we
can give a name e.g. placeOrder as interaction
o Cancel name and selected rcv as interaction type.
06
SRML Wizard - Specification (11)Ad d Interaction
Create Business Role, Business Protocol, Layer Protocol and Interaction Protocol in the SRML Param eter —
specification
= © SR Specication I En e e Switch to Parameters
> @ sasyBank o nctors [ tab and add a new
1 placeOrder _ parameter product of
et v e ProductType.
Select < (request)
< N as interaction event
<| <> type.

Add Delete selecte
Add Delete

7 < Back Mext = Einish Cancel



SRML Specification-Business Role

2 Interaction forwardBill
SRML Wizard - Specification General Parameters | Retum
Create Business Role, Business Prot
Event Type Data Type Wariable
tequest | % | BillType w | hill
= @ SRML Specification
= (@ easyBank
0 placeCrder
€ dolrvoice el Nes>
I forwardsil
Add Delete selecte

(12)Now let’s add other two interactions:
S <> dolnvoice
Add Delete forwardBill
as defined in lecturer note:

rev placelrder
& product:ProductType
s&kr doinvoice
&£ product:ProductType
] pill:BillType
snd forwardBill
£ bill:BillType




SRML Specification-Business Protocol

= 06
SRML Wizard - Specification

(12)The same for

Create Business Role, Business Protocol, Layer Protocol and Interaction Protocol in the SRML B US| n eSS P I’OtOCO|
specification . . .
InvoiceService and
< @ SRML Specification Business Protocol Bu yer
b @ easyBank Name  buver
b G invoiceService
Datatypes avaiable Importec BUSINESS PROTOCOL invoiceService is
© placeOrder BOOL EasyBankType INTERACTIONS
€ receivesil STRING 5% r&s dolInvolce
£ product:ProductType
bill:BillType
<< BEHAVIOUR
<| H<>
Add Delete

BUSINESS PROTOCOL buyer is

INTERACTIONS
snd placeOrder
L product:ProductType
@) < Back Next > Finish Cancel rov re:ie l".?.E!E:Lll_
= bill:BillType
BEHAVIOUR

(13) Click Next when you finish.



SRML Module Node

Let’s add these module nodes :

‘ Provide Interface

Component

- Require Interface




SRML Module Node - Component

06 (13) Switch to
SRML Wizard - SRML Module configuration CO m p onents tab in
Create and initialise SRML Component and Interfaces SR M L M 0 du Ie
configuration window
Components | Requires  Provides Uses  Serves  Wires then add com ponent
EB of type easyBank
Business Role Cornponent Marme Add
easyBank v [EB
Delete

(7 = Back Mext = Firish Cancel



SRML Module Node - Require Interface

o )

ML Wizard - SRML Modul fi ti e (14) SWItCh to

izard - odule configuration . .

Create and initialise SRML Component and Interfaces ReqUIreS tab In SRML
Module configuration
window then add

Components  Requires | Provides  Uses  Serves  Wires . .
require interface IS of
type invoiceService

Business Protocol Require Interface Add

invoiceService v [ IS|
Delete

>

3] < Back Mext = Einish Cancel



SRML Module Node — Provide Interface

06
SRML Wizard - SRML Module configuration

Create and initialise SRML Cormmponent and Interfaces

(15) Switch to Provide
tab in SRML Module
configuration window
then add require
interface BU of type
buyer

Components  Reguires  Provides | Uses  Serves  Wires

Business Protocol Provide Interface Add

bLyer B
Delete

20

[ @ = Back Mext = Firishi Cancel



Create SRML Wires

T Mew Wire (5]
Mlarme
(& ) oK (16) Add Wires
Mode & Hode B
EE === — IS — Can—cel B E (B U 9E B)
I Mew Wire &)
Bl (EB-IS)
BE (04
MNode A MNode B
BU — == EE ) Cancel
=13 L
o6 e
YBANKPROCESS
SRML Wizard - SRML Module configuration
Create and initialise SRML Cormponent and Interfaces

Companents  Requires  Provides Uses Serwes | Wires

Marne niodes, nodeB

BE ] Bl — (] EE

BI | EBE — (D) IS
Add Delete

(2) < Back MNext = Finish Cancel




Finished !

» Click Finish to generate code.*

Plug-in Development - easyBankfsrcfmodel.srnl - Eclipse SDK

Fle Edit Mavigate Search Project Sample Menu Run  Window  Help

==
< 12 sasyBark
= (Bsrc

[F) easyBank.oaw

@ model.srml_diagram

[ src-gen
P = JRE Systemn Library [java-6-sun-1.6
P =4 Plug-in Dependencies
b G2 META-INF
|n—'_|‘1 build.properties
< E srmiproject
= GFBsic
FEl model.srml
[F] srmiproject.oaw
[ src-gen
P =4 IRE Systern Library [java-6-sun-1.6
P =i Plug-in Dependencies
b i META-INF
[&té build properties
P2 uk.ac ke test
I b‘Jum\2path
b 52 UML2SRML

Clamm . <>

A

| [ | cample Action | v Qv Qv [ & B Gy | = v
[% Package Expl 32 3 Plugdns| = O || d uk.acle.test ITestToal java [J] ITestToollmpl java
/4 SRML source code generated by SRML Wizard (c) University of Leicester

@] Error Log 52

service easyBank is

components
EB : easyBank {
intOR[init] : true;
intOR[term] : true;
i
requires
15 : invoiceService {

intGaltrigger] : true;

provides

BU: huyer

wires
BE{
nodeA BU;
nodeB EB;
H
EI{
nodeA EB;

nadaP T

v KD ow chw

[=] madel.srml £3

& *rnodel.srml

06ee

F ==Plug-n Dev... >

P15 = 0| 3= outiine &2 A v =0
N P @ EasyBarnkType
b @ BOOL
b @ STRING

P e

invoiceservice

-
L]

buiyer

-
L]

easyBanlk

<>

<

‘Workspace Log
type fiter text

Message

2 Tasks | (24 Prablems | B Cansole

Plug-in

Date

Writable

Insert

<>

22955

* If error occurs, please change activity ... enda pair to service ..ends



Visualize SRML file

* To enable Graphical Editor (GE), you can right click
model.srml and select initialise srml_diagram_file

e Double click model.srml_diagram to open GE.

4 = srmlproject
4 [ src
[iz] EasyBank srml
|d| EasyBan New

2] model.s| 0
| model.s| pen
£ model2] Open With
| model2, Show In
| srelpro)
(= sre-gen ||| Copy
- =) JRE System | E5  Cepy Qualified Name
- B Plug-in Dep 2, Paste
- = META-INF Delete
|md build.prope
PR srmlprojectl
a [ src Vedhesls
E mDTE"S Build Path
srmlpro)
(# src-gen Refactor
- B JRE System | -, Import..
- =i Plug-in De
- Hea Export...

4 7= META-INF | =
e MANIFE < Refresh

lsb build.prope Aszign Working Sets...

Validate

Initialize srenl_diagram diagram file

EasyBank
2
BE EE
Functionalities:

(1)Create component and interface
(2)Create wires between them
(3)Reflect update to the source code Iin
textural editor



Practise

Complete your EasyBank example
* Task

> Get familiar with basic SRML syntax
> Write a Business Role and Business Protocol without wizard.

> Try adding one Require Interface “DeliveryService” to the
existing SRML file with the Graphical Editor

*Tips:
(1) Read a completed SRML document:
http://www.cs.le.ac.uk/srml/example/travelBooking.txt
(2) Full SRML syntax specification (BNF-linked grammar)
can be found here:
http://www.cs.le.ac.uk/srml/example/srml_grammar.txt



SRML Modelling Environment
Installation

=
%
PN

¥

SRML Modeling Environment is an Eclipse plugin thus can be
installed and run on any platforms (windows/Linux)

e The latest version of SRML Model environment can found on this update
site:

o Step | download Eclipse 3.4 from
(Eclipse 3.4 SR2 (Ganymede)

* Please download this release: "Eclipse Modeling Tools (includes
Incubating components) )

o Step 2 install openArchitectureWare 4.3.1 for Eclipse 3.4/SDE from

(Menu: Help->Software Updates->Availables Software->add Site)


http://www.cs.le.ac.uk/srml/milestone/update/site.xml
http://www.eclipse.org/downloads/packages/release/ganymede/sr2
http://www.openarchitectureware.org/updatesite/milestone/site.xml

SRML Modelling Environment
Installation

e Step 3 install SRML Modeling Environment from

e (Menu: Help->Software Updates->Availables Software->add Site)
-%SoftwarEUpdatesandAdd-qns —E )

Installed Software| Available Software
- Install...

MName Version o

[7] %] Eclipse Update Site
[7] %] EMF Update Site

[7] %] EPP Usage Data Collector Update Site

0 4l Gamymede Add Site..
[[] %] GMF Update Site

0 \rﬂ http://download.eclipse.org/modeling/gmf/update-site/releases/sitexml

[} \rﬂ http://download.eclipse.org/tocls/emf/updates/

= Properties

|:| \rﬂ http://download.eclipse.org/tocls/gef/update-site/releases/sitexml

51 &l bt faclines mmbit cam D vl

Show only the latest versions of available software
[#]Include iterms that have already been installed

Open the 'Automatic Updates' preference page to set up an automatic update schedule.

. |

Once the installation is completed, go to File->New->Other-
>srmlProject
and follow the wizard to generate a simple SRML file.



https://securewebmail.le.ac.uk/owa/redir.aspx?C=bf4bc049e4464e749a515c9ae7379bcc&URL=http://www.cs.le.ac.uk/srml/milestone/update/site.xml

